New test version of bomac 1.5.0 / GMA2 V3.1 workaround

Post Reply
Site Admin
Posts: 131
Joined: Tue Oct 22, 2013 9:54 am

New test version of bomac 1.5.0 / GMA2 V3.1 workaround

Post by bernd »

Hi users,

after a update from MA for their GMA2 Console Software V3.1 - bomac stopped working with it.
They heavily modified their Art-Net stack. This forced me to check my stack, too.

Finally i found a small bug. Bomac has send the Art-Net version in wrong order. Additionally i modified the Art-Net subnet and universe settings in the dialogs to fit more into Art-Net 3 protocol.
But that wasn't the reason why it stopped working with GMA2.
After some tests i found out, that they only accept Art-Net packages from other IPs.

This forced me to change the project settings dialog. In this dialog there a now a new tab "special".
There you can enter an IP address which is used as "sender" IP. Normally you can leave this field empty, but if you want to use GMA2 on the same PC as bomac runs on, you need to do two things:
1) You need to assign your PC two Art-Net IPs like and GMA2 used the highest one (in my tests). You see it in the window detected Art-Net nodes.
2) You need to enter the lower IP in this special LocalIP field.

After this everything should work as known.

Test versions can be unstable and should not used in production!
bomac 1.5 uses a new file format. you can open old project files, but you need to check/edit the universe settings!
Pre 1.5 versions of bomac CAN'T open the new file format! If you test or you plan to downgrade, make a copy of your project file first!

Here is the new test version: ... -1.5.0.msi
Post Reply