Art-Net and GrandMA2 Version 3.1 or later

Post Reply
bernd
Site Admin
Posts: 125
Joined: Tue Oct 22, 2013 9:54 am

Art-Net and GrandMA2 Version 3.1 or later

Post by bernd » Tue Nov 24, 2015 1:19 pm

MALighting change in the software 3.1 the Art-Net handling.
They also have a bug in Art-Net configuration. If you are using different networks, you need to enter them manual into the project dialog. GrandMa send wrong Art-Net reply packets, which do not contain the network number! In other words: If you use the automatic configuration, the network will be wrong if you are not using network 0 (zero).

Since version 3.1 the Grandma only accepts Art-Net packages from other Sender IPs.

This forced me to change the project settings dialog. In this dialog there a now a new tab "special".
There you can enter an IP address which is used as "sender" IP. Normally you can leave this field empty, but if you want to use GMA2 on the same PC as bomac runs on, you need to do two things:
1) You need to assign your PC two Art-Net IPs like 10.0.0.1 and 10.0.0.254. GMA2 used the highest one, i my tests. You see it in the detected Art-Net nodes.

Assign Multiple IP address in Windows OS

2) You need to enter the lower IP in this special LocalIP field.

After this everything should work as known.



Pay attention using version =3.1, =3.3
There are a lot of bugs in the newer Art-Net implementation.
I know at least two bugs.
1) Art-Net "Network" is not send not correctly by MA
2) If you create an input which span over 2 or more universes and universe number is so high that the next universe needs to be in a new sub-net, then the sub-net number is not transferred correctly.

ALWAYS CHECK UNIVERSE, SUB-NET and NETWORK if you are using the automatic configuration.

Since 3.2 they fixed the problem.
In 3.3 there are also problems.

Post Reply